Educating the world

Our blog has over 10,000 readers a month

« VNC SlownessFinding my clearcase checkins between 2 dates »

9 comments

Comment from: Brendan [Visitor]
Brendan

I need to also PMD from http://pmd.sourceforge.net/eclipse/ for step 19 to work.. Brendan

01/07/09 @ 14:40
Comment from: davidnewcomb [Member]  
admin

How did you know that you needed to install this? What error message did it give you?

01/07/09 @ 15:07
Comment from: Elavarasan [Visitor]
Elavarasan

I’m getting this error during the step 19.
Cannot complete the install because one or more required items could not be found.
Software being installed: SpringSource Tool Suite Grails Support 2.3.0.200911170805-CI-R4083-B18 (com.springsource.sts.grails.feature.group 2.3.0.200911170805-CI-R4083-B18)
Missing requirement: SpringSource 2.3.0.200911170805-CI-R4083-B18 (com.springsource.sts.grails.ui 2.3.0.200911170805-CI-R4083-B18) requires ‘bundle org.codehaus.groovy.eclipse.core 2.0.0′ but it could not be found
Cannot satisfy dependency:
From: SpringSource Tool Suite Grails Support 2.3.0.200911170805-CI-R4083-B18 (com.springsource.sts.grails.feature.group 2.3.0.200911170805-CI-R4083-B18)
To: com.springsource.sts.grails.ui [2.3.0.200911170805-CI-R4083-B18]

17/11/09 @ 10:55
Comment from: Mx [Visitor]
Mx

Just to be verbose - I did need WTP, Maven (which needed Subclipse as well)

23/12/09 @ 06:38
Comment from: Ruslan Masold [Visitor]
Ruslan Masold

all what you need now is
http://www.springsource.com/update/e3.5

23/12/09 @ 16:33
Comment from: Otto [Visitor]  
Otto

I am having the same issue. Did any of you find a resolution for this?
I tried running the install from “http://www.springsource.com/update/e3.5″ but also got missing requirement errors.

01/02/10 @ 20:45
Comment from: wp moore-taylor [Visitor]
wp moore-taylor

you may also need to include a line to add the basic

Mylyn Task List (Required) 3.3.1.v20091215-0000-e3x org.eclipse.mylyn_feature.feature.group

or step 8 may well fail.

04/02/10 @ 13:40
Comment from: Sabir Hussain [Visitor]
Sabir Hussain

If you like to install spring tool suite on eclipse galileo SR2 and facing a problem saying mylyn feature group [some-version] is missing, or any similar error, that means your eclipse dont have the required version of that plugin or feature, to resolve such issue follow this:

1) fix the version of the required plugin or feature (ex: on eclipse galileo SR2 mylyn feature group 3.2.3 was available, but STS required mylyn 3.3.3, so I updated the mylyn feature group with 3.3.3 version [see: http://www.eclipse.org/mylyn/builds/ for desired version], currently STS dont support mylyn 3.4 so you have to update from older builds of mylyn that is 3.3.3)

Mylyn update site for eclipse
a) Mylyn 3.3.3: http://download.eclipse.org/tools/mylyn/update-archive/3.3.3/v20100330-0100/e3.4

b) Mylyn Extras 3.3.3: http://download.eclipse.org/tools/mylyn/update-archive/3.3.3/v20100330-0100/extras

2) update only plugin or feature that is required, and that is all you are done. Now you STS install should be flawless.

27/06/10 @ 08:17
Comment from: here [Visitor]
12/02/11 @ 18:03

Leave a comment


Your email address will not be revealed on this site.

Your URL will be displayed.
  
(For my next comment on this site)
(Allow users to contact me through a message form -- Your email will not be revealed!)